aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfgang Draxinger <code+github@datenwolf.net>2011-09-21 15:28:20 +0200
committerWolfgang Draxinger <code+github@datenwolf.net>2011-09-21 15:28:20 +0200
commiteeccf5391e0e372219e102b0321bd9d5d7c33024 (patch)
tree1eb7f48f3cfd11a8fb63cc9087bea559fb2150eb
parentb7bf2783c62fb6d6441bfd43c7e0048baa9415dc (diff)
downloadpam_propperpwnam-eeccf5391e0e372219e102b0321bd9d5d7c33024.tar.gz
pam_propperpwnam-eeccf5391e0e372219e102b0321bd9d5d7c33024.tar.bz2
debian package builds successfully
-rw-r--r--Makefile5
-rw-r--r--debian/control10
-rw-r--r--debian/dirs1
-rw-r--r--debian/files1
-rw-r--r--debian/pam-propperpwnam-dev.debhelper.log6
-rw-r--r--debian/pam-propperpwnam.debhelper.log45
-rw-r--r--debian/pam-propperpwnam.substvars2
-rw-r--r--debian/pam-propperpwnam/DEBIAN/control11
-rw-r--r--debian/pam-propperpwnam/DEBIAN/md5sums4
-rw-r--r--debian/pam-propperpwnam/usr/share/doc/pam-propperpwnam/README39
-rw-r--r--debian/pam-propperpwnam/usr/share/doc/pam-propperpwnam/changelog.gzbin0 -> 156 bytes
-rw-r--r--debian/pam-propperpwnam/usr/share/doc/pam-propperpwnam/copyright48
12 files changed, 163 insertions, 9 deletions
diff --git a/Makefile b/Makefile
index 7146021..7284b3e 100644
--- a/Makefile
+++ b/Makefile
@@ -4,8 +4,9 @@ pam_propperpwnam.so: pam_propperpwnam.c
.PHONY: clean
clean:
- rm *.o *.so
+ rm -f pam_propperpwnam.so
install: pam_propperpwnam.so
- install -o root -g root -m 644 pam_propperpwnam.so $(DESTDIR)/lib/security/
+ mkdir -p $(DESTDIR)/lib/security
+ install -o root -g root -m 644 -t $(DESTDIR)/lib/security/ pam_propperpwnam.so
diff --git a/debian/control b/debian/control
index 064f28c..fcc9bd7 100644
--- a/debian/control
+++ b/debian/control
@@ -1,18 +1,14 @@
Source: pam-propperpwnam
Priority: extra
Maintainer: Wolfgang.Draxinger <Wolfgang.Draxinger@physik.uni-muenchen.de>
-Build-Depends: debhelper (>= 7) libpam0g-dev
-Depends: libpam0g
+Build-Depends: debhelper (>= 7), libpam0g-dev
Standards-Version: 3.8.3
Section: libs
Homepage: https://github.com/datenwolf/pam_propperpwnam
-Description: Prop username per pwnam API
- Props the entered login credentials with user information retrieved per pwnam API (getpwnam)
-Package: pam-propperpwnam-dev
-Section: libdevel
+Package: pam-propperpwnam
Architecture: any
-Depends: pam-propperpwnam (= ${binary:Version}) libpam0g-dev
+Depends: pam-propperpwnam (= ${binary:Version}), libpam0g
Description: Prop username per pwnam API
Props the entered login credentials with user information retrieved per pwnam API (getpwnam)
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..ac2bef0
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1 @@
+/lib/security/
diff --git a/debian/files b/debian/files
new file mode 100644
index 0000000..f4de78f
--- /dev/null
+++ b/debian/files
@@ -0,0 +1 @@
+pam-propperpwnam_0.1_amd64.deb libs extra
diff --git a/debian/pam-propperpwnam-dev.debhelper.log b/debian/pam-propperpwnam-dev.debhelper.log
new file mode 100644
index 0000000..2742cb4
--- /dev/null
+++ b/debian/pam-propperpwnam-dev.debhelper.log
@@ -0,0 +1,6 @@
+dh_auto_configure
+dh_auto_build
+dh_auto_test
+dh_prep
+dh_installdirs
+dh_auto_install
diff --git a/debian/pam-propperpwnam.debhelper.log b/debian/pam-propperpwnam.debhelper.log
new file mode 100644
index 0000000..2d06fcd
--- /dev/null
+++ b/debian/pam-propperpwnam.debhelper.log
@@ -0,0 +1,45 @@
+dh_auto_configure
+dh_auto_build
+dh_auto_test
+dh_prep
+dh_installdirs
+dh_auto_install
+dh_install
+dh_installdocs
+dh_installchangelogs
+dh_installexamples
+dh_installman
+dh_installcatalogs
+dh_installcron
+dh_installdebconf
+dh_installemacsen
+dh_installifupdown
+dh_installinfo
+dh_pysupport
+dh_installinit
+dh_installmenu
+dh_installmime
+dh_installmodules
+dh_installlogcheck
+dh_installlogrotate
+dh_installpam
+dh_installppp
+dh_installudev
+dh_installwm
+dh_installxfonts
+dh_bugfiles
+dh_lintian
+dh_gconf
+dh_icons
+dh_perl
+dh_usrlocal
+dh_link
+dh_compress
+dh_fixperms
+dh_strip
+dh_makeshlibs
+dh_shlibdeps
+dh_installdeb
+dh_gencontrol
+dh_md5sums
+dh_builddeb
diff --git a/debian/pam-propperpwnam.substvars b/debian/pam-propperpwnam.substvars
new file mode 100644
index 0000000..e64e0e7
--- /dev/null
+++ b/debian/pam-propperpwnam.substvars
@@ -0,0 +1,2 @@
+shlibs:Depends=libc6 (>= 2.2.5), libpam0g (>= 0.99.7.1)
+misc:Depends=
diff --git a/debian/pam-propperpwnam/DEBIAN/control b/debian/pam-propperpwnam/DEBIAN/control
new file mode 100644
index 0000000..a42bb74
--- /dev/null
+++ b/debian/pam-propperpwnam/DEBIAN/control
@@ -0,0 +1,11 @@
+Package: pam-propperpwnam
+Version: 0.1
+Architecture: amd64
+Maintainer: Wolfgang.Draxinger <Wolfgang.Draxinger@physik.uni-muenchen.de>
+Installed-Size: 52
+Depends: libpam0g
+Section: libs
+Priority: extra
+Homepage: https://github.com/datenwolf/pam_propperpwnam
+Description: Prop username per pwnam API
+ Props the entered login credentials with user information retrieved per pwnam API (getpwnam)
diff --git a/debian/pam-propperpwnam/DEBIAN/md5sums b/debian/pam-propperpwnam/DEBIAN/md5sums
new file mode 100644
index 0000000..a0bc58e
--- /dev/null
+++ b/debian/pam-propperpwnam/DEBIAN/md5sums
@@ -0,0 +1,4 @@
+b25d663638284add6aa983147c38c219 usr/share/doc/pam-propperpwnam/changelog.gz
+54cc06c0f2af13bd235074c425bc370e usr/share/doc/pam-propperpwnam/README
+f995ead7ca8e8308b06c4cc33da3562f usr/share/doc/pam-propperpwnam/copyright
+b1450c12bf17e035078188a5df5dafc2 lib/security/pam_propperpwnam.so
diff --git a/debian/pam-propperpwnam/usr/share/doc/pam-propperpwnam/README b/debian/pam-propperpwnam/usr/share/doc/pam-propperpwnam/README
new file mode 100644
index 0000000..53eed04
--- /dev/null
+++ b/debian/pam-propperpwnam/usr/share/doc/pam-propperpwnam/README
@@ -0,0 +1,39 @@
+pam_propperpwnam
+
+A PAM module that uses the entered login name as key to
+query the password database configured through nsswitch.conf
+and replaces the login name with what has been returned.
+
+On the typical system this module performs an identity transform.
+The main usage scenario are systems in networks where a user name
+is used in several distinct authentication systems, some of them
+being case sensitive and others not. For example the mail system
+may do case insensitive username lookups, while the workstations
+are case sensitive. In such environments users are often puzzeled
+about a username working in one situation does not work in another.
+
+Actually this module has been written for this very reason.
+
+CONFIGURATION
+
+pam_propperpwnam.so needs no configuration except adding it as "optional"
+early in in the list of PAM modules executed for user authentication.
+A good place in most distributions is /etc/pam.d/common-auth
+
+Example configuration, authentication with rewritten username against
+Kerberos5 infrastructure:
+
+ auth [success=done new_authtok_reqd=done default=ignore] pam_unix.so
+ auth optional pam_propperpwnam.so
+ auth required pam_krb5.so use_first_pass forwardable
+ auth required pam_permit.so
+ auth optional pam_group.so
+
+BUGS AND ISSUES
+
+Probably there are some, but they are not known yet.
+
+AUTHOR
+
+Wolfgang Draxinger, Wolfgang.Draxinger@physik.uni-muenchen.de
+
diff --git a/debian/pam-propperpwnam/usr/share/doc/pam-propperpwnam/changelog.gz b/debian/pam-propperpwnam/usr/share/doc/pam-propperpwnam/changelog.gz
new file mode 100644
index 0000000..8d12707
--- /dev/null
+++ b/debian/pam-propperpwnam/usr/share/doc/pam-propperpwnam/changelog.gz
Binary files differ
diff --git a/debian/pam-propperpwnam/usr/share/doc/pam-propperpwnam/copyright b/debian/pam-propperpwnam/usr/share/doc/pam-propperpwnam/copyright
new file mode 100644
index 0000000..8d733e8
--- /dev/null
+++ b/debian/pam-propperpwnam/usr/share/doc/pam-propperpwnam/copyright
@@ -0,0 +1,48 @@
+This work was packaged for Debian by:
+
+ Wolfgang.Draxinger <Wolfgang.Draxinger@physik.uni-muenchen.de> on Mon, 12 Sep 2011 14:29:52 +0200
+
+It was downloaded from:
+
+ https://github.com/datenwolf/pam_propperpwnam
+
+Upstream Author(s):
+
+ Wolfgang Draxinger, Wolfgang.Draxinger@physik.uni-muenchen.de
+
+Copyright:
+
+ Copyright (C) 2011 Wolfgang Draxinger
+
+License:
+
+Licensed under the terms of the BSD 2-Clause License
+
+Copyright (c) 2011, Wolfgang Draxinger
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+ Redistributions of source code must retain the above copyright notice,
+ this list of conditions and the following disclaimer.
+
+ Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE
+LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+The Debian packaging is:
+
+ Copyright (C) 2011 Wolfgang.Draxinger <Wolfgang.Draxinger@physik.uni-muenchen.de>
+